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Foreword

KalimbaScore is Windows Software for creating kalimba tabs. It is programmed by Fred
Bolder. You can download it from the following site:
http://www.dansblad.nl/kalimba/

KalimbaScore works under Windows 7, but Windows 10 is recommended. It has the
following functionality:

Saving and opening a kalimba tab
Creating a kalimba tab by entering musical notes
Entering triplets
Using ties to connect notes of the same pitch
Automatic note beaming depending on the time signature (user grouping possible)
Using almost every possible time signature (some examples: 2/2, 3/4, 4/4, 5/4, 9/4, 5/8,
6/8, 7/8 and 15/16)
Printing the tab (also printing to PDF file)
Playing the music at the desired tempo
Exporting as PNG, BMP, GIF or JPG picture(s)
Exporting to MIDI file
and more.....

Feel free to send an e-mail to fgh.bolder@gmail.com if you have a question or feedback.

Disclaimer

Although a lot of care is taken to create KalimbaScore, Fred Bolder cannot be held
responsible for any data loss, virus, computer bug or damage to the computer.

http://www.dansblad.nl/kalimba/
mailto:fgh.bolder@gmail.com
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Quick start

If the Microsoft .NET Framework Runtime is not yet installed on your Windows computer,
you need to download and install it.
http://dotnet.microsoft.com/download

KalimbaScore uses the Microsoft XNA Framework which you need to download and install.
http://www.microsoft.com/en-us/download/details.aspx?id=20914

Download and install KalimbaScore.
http://www.dansblad.nl/kalimba/

Start KalimbaScore.exe.

http://dotnet.microsoft.com/download
http://www.microsoft.com/en-us/download/details.aspx?id=20914
http://www.dansblad.nl/kalimba/
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Installing and starting KalimbaScore

If the Microsoft .NET Framework Runtime is not yet installed on your Windows computer,
you need to download and install it.
http://dotnet.microsoft.com/download

KalimbaScore uses the Microsoft XNA Framework which you need to download and install.
http://www.microsoft.com/en-us/download/details.aspx?id=20914

Go to:
http://www.dansblad.nl/kalimba/
Click with the right mouse button on “Download and install KalimbaScore” and choose
something like “Save target as” or “Save link as...”.
Choose the folder where you want to save the file and press the Save button.
Click with the right mouse button on the Windows Start button and choose File Explorer.
Browse to the folder where you have saved kalimbascoresetup.exe.
If you don’t see the file, the download might have failed or the file is removed by your virus
scanner and you have to recover it.
Double click on kalimbascoresetup.exe (keep in mind that the extension can be hidden).
If the following message appears, click on More info and then on Run anyway.

http://dotnet.microsoft.com/download
http://www.microsoft.com/en-us/download/details.aspx?id=20914
http://www.dansblad.nl/kalimba/


6

Press the Yes button, if a question like “Do you want to allow this app from an unknown
publisher to make changes to your device?” appears.

Normally you don’t need to change the folder where KalimbaScore will be installed and you
can just press the Next button.
If you want to change the folder, you can press the Browse button.

Press the Next button.
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Enable “Create a desktop shortcut” if you want to be able to easily start frEDrums from your
desktop.
Press the Next button.

Press the Install button.
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If you don’t want to start already KalimbaScore, disable “Launch KalimbaScore”.
Press the Finish button.

Starting KalimbaScore

After you have installed KalimbaScore, you can start it by double clicking on the
KalimbaScore shortcut on your desktop or by choosing from the start menu KalimbaScore
and again KalimbaScore.
You can also go (with the File Explorer) to the folder where you have installed KalimbaScore
and double click on KalimbaScore.exe (keep in mind that the extension can be hidden).
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Creating, opening and saving a kalimba tab

If the music is playing, you need first to press the Stop button.
A KalimbaScore tab file has the extension .ksc.

New

Choose New from the File menu or press Ctrl-N to create a new kalimba tab.

It is best first to check if there is already a template of your kalimba. Click in the box behind
Kalimba to see the list of available kalimba templates. If you see your kalimba, click on it and
press the OK button.
If your kalimba is not in the list, you can make your own template.
Enter the notes of your kalimba from left to right by chosing the note and the octave and
pressing the Add button. If you prefer to see a flat instead of a sharp, enable “Use a flat (b)
instead of a sharp (#)”. The notes that are already in the list will not be changed, but you can
change a note by selecting it, chosing the note and the octave and pressing the Change button.
If you have forgotten a note, you can insert it above a note in the list, by selecting that note,
chosing the note and the octave and pressing the Insert button. You can delete a note by
selecting the note and pressing the Delete button. Press the Delete all button and then the Yes
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button to delete all notes. You can change the order of the notes by selecting a note and using
the Up or Down button.
Press the Write to file button, if you want to save your kalimba template, in case you need it
another time. A KalimbaScore template file has the extension .kst. You can load a kalimba
template by pressing the Load from file button.
Press OK when your template is ready.

Open

Choose Open from the File menu or press Ctrl-O to open an existing kalimba tab that is made
with KalimbaScore.

Save

Choose Save from the File menu or press Ctrl-S to save the current kalimba tab. If the file
already exists, a question appears if you want to replace the file. Press the Yes button to
overwrite the existing file. Before replacing the file, a backup with the extension .bak will be
created. When necessary, you can rename the backup to a ksc file.
Keep in mind that on most computers you need Administrator rights to save a file under
C:\Program Files (x86)\
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Entering musical notes and rests

It is handy to first set the time signature. The top number indicates how many beats there are
in one measure (bar) and the bottom number indicates which note gets the beat (2 = half note,
4 = quarter note, 8 = eighth note and 16 = sixteenth note).
Select the musical note that you want to use from the note menu at the right and click in the
cell where you want to enter it. Keep in mind that a kalimba tab is read from bottom to top. If
you click in a cell which has already a note, the note will be removed. If there are more notes
in the same row, they will be played simultaneously. There can not be notes with different
durations in the same row. If you enter a note, all notes in the row will change to the duration
of the last entered note. Therefore you can easily change the duration of a row by selecting a
note with the desired duration from the note menu and clicking twice in the same cell.
If you hold the Alt button while entering a note, the note will be the same as the other notes
(if exist) in the row, so in that case the selected note in the note menu will be ignored.

To enter a rest, make sure that Rest is enabled. There can only be one rest per row. If you
enter a rest in a row that has already a rest, that rest will be removed.
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Here is an overview of note durations.

The duration of a note or a rest depends on the time signature.
A dot after a note or a rest increases its duration by half. In KalimbaScore there are also
double dotted notes available. A second dot after a note is half the value of the first dot, so the
duration of a double dotted quarter note in 4/4 time is 1 + 0.5 + 0.25 = 1.75 beats.
You can also use one or more ties to arrive to a certain duration.
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While editing, the timing is checked. If the total duration of the notes in a measure exceeds
the duration of that measure, a warning will appear and the start and end of the rows will
color red from the point with the timing error.

There are 3 dotted quarter notes in the first measure. In 4/4 time, a dotted quarter note has a
duration of 1 + 0.5 = 1.5 beats. The total duration is 3 x 1.5 = 4.5 beats and that exceeds the 4
beats per measure. If you change one of the notes to a quarter note, the warning will disappear
(1.5 + 1.5 + 1 = 4).
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Entering triplets

A triplet in KalimbaScore consists always of 3 contiguous rows. Select the first row, hold the
shift key while selecting the last row and press the Triplet button. If the rows are empty, you
will get the following result.

Now you can enter notes wherever you like.

For a quarter note triplet, you can just enter quarter notes. Don’t worry if there appears a
timing error when you are not ready with the triplet. As you can see, you can also enter more
notes in the same row. They will be played simultaneously.

Within a triplet you can also use ties. Read the Using ties chapter for more information about
ties.
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Instead of the previous example, you can enter the following. In this case the middle row must
be totally empty, so also no rest.

Here is another example with notes with different durations. In this case the last row must be
totally empty.

Within a triplet there can also be a combination of notes and rests.

To delete a triplet (not the notes or rests), select the 3 contiguous rows and press the Triplet
button.

In KalimbaScore a triplet must always be within a measure (bar). Nested triplets are not
possible.
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Using ties

Tied notes are played as a single note with the total duration of the tied note values. To tie
notes with the same pitch, select 2 contiguous rows and press the Tie button. There will only
be a tie (curved line) between two notes, if they have the same pitch.

In the following example, ties are used for a note that has a longer duration than the duration
of the measure.

Here are some more examples.

You can delete a tie by selecting 2 contiguous rows that are tied with each other and then
press the Tie button. To delete more ties, you can select the rows from which you want to
remove the ties, choose Delete selected tie(s) from the Edit menu and then press the Yes
button.
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Editing rows

Selecting rows

For most commands, it is necessary to select one or more rows. You can select a row by
clicking with the left mouse button on the left end of a row. Hold the Ctrl key while selecting,
if you want to add more rows to the selection. If you click on a row that is already selected, it
will be removed from the selection. If you want to select contiguous rows, select the first row
and hold the shift key while selecting the last row. In the following example, the rows 1, 2
and 4 are selected.

Adding rows

Choose Add 8 rows from the Edit menu or press Ctrl-8 to add 8 rows at the end. It doesn’t
matter if you need less than 8 rows, since empty rows will be removed automatically.
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Inserting rows

Select a row where you want to insert one or more rows and choose Insert row(s) from the
Edit menu or press Ctrl-I.

Select the number of rows that you want to insert and choose if you want to insert the rows
above or below the selected row.

Deleting rows

Select the row(s) that you want to delete, choose Delete selected row(s) from the Edit menu or
press Ctrl-Y and then press the Yes button.

Clearing rows

Select the row(s) that you want to clear, choose Clear selected row(s) from the Edit menu and
then press the Yes button.

Copying rows

Select the row(s) that you want to copy, choose Copy from the Edit menu or press Ctrl-C,
select the row where you want to copy above and choose Paste from the Edit menu or press
Ctrl-V.
You can copy to more positions by again selecting a row and choosing Paste.

Moving rows

Select the row(s) that you want to move, choose Cut from the Edit menu or press Ctrl-X,
select the row where you want to move above and choose Paste from the Edit menu or press
Ctrl-V.
When you choose Cut from the Edit menu, the selected rows will be removed immediately.
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Changing the settings

Options

Choose Options from the Settings menu to change the options.

Tine shading color

For easier finding the notes on your kalimba, you can color some of the tines. On the tines of
your real kalimba you can put stickers. In KalimbaScore you can double click on a column
header to switch the shading of that tine on or off. In the Options screen you can set your
preferred shading color.

Play note when entering it

Enable this option when you want to hear the note at the moment that you enter it.

Play note(s) when selecting a row

Enable this option when you want to hear the note(s) in the row that you select.
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Always play from beginning

You can play the music from the selected row, but if you always want to play the whole song,
it is better to check this option.

Use C5.wav also for C4 scale

In KalimbaScore there is normally used one wav file per octave. If C5.wav (instead of
C4.wav) is used for the C4 scale, the notes will sound brighter.

Playing volume

Use this setting to adjust the volume. 100% is the loudest volume.

Scroll mode

You can set how the tab scrolls while the music plays (1 = the current row is mostly in the
middle, 2 = scroll only when needed).

Count off bars

When you want to play along, it is handy that the music not immediately starts to play. You
can set the number of count off bars. When you play the music from a selected row, it will
start immediately.

MIDI instrument for export

Enter here the number of your preferred instrument for export to a MIDI file (108 = Kalimba,
8 = Celesta). On the following internet page you can find an instrument list, but you have to
substract the number by 1.
http://en.wikipedia.org/wiki/General_MIDI
This setting has to influence on the sound that is used for playing the music within
KalimbaScore.

MIDI velocity

Enter here the velocity of all notes for export to a MIDI file. The velocity corresponds with
how hard a note is hit. Normally a higher velocity value will result in a higher volume level,
but the brightness can also change.

http://en.wikipedia.org/wiki/General_MIDI
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Show music title

Enable this option, if you want to see the music title on a print or an exported picture.

Show tempo

Enable this option, if you want to see the tempo on a print or an exported picture. The tempo
will be indicated in quarter notes per minute, which is the same as beats per minute if a
quarter note gets the beat (if bottom number of time signature = 4).

Show composer

Enable this option, if you want to see the composer on a print or an exported picture.

Click on the OK button when you are ready.

Tuning

To change the tuning, choose Tuning from the Settings menu.

Enable Use a flat (b) instead of a sharp (#) when you prefer to see flats.
You can increase the pitch of a tine one semitone by clicking on the corresponding plus.
You can decrease the pitch of a tine one semitone by clicking on the corresponding minus.
You can transpose all tines at the same time by clicking on the most left plus and/or minus.
Click on the OK button when you are ready.
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Playing the kalimba tab

Set the desired tempo and press the play button to play the kalimba tab. The empty rows will
be removed. If the option Always play from beginning (see Changing the settings) is enabled,
the music will play from the beginning. If that option is disabled and there is a row selected,
the music will play from the selected row. Press the Stop button to stop the music.
You can press the Rewind button to go to the beginning of the music.
See the Changing the settings chapter for the different scroll modes and other options.
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Printing and exporting pictures

Choose Print / Export pictures from the File menu to print or to export to pictures.

For exporting to pictures, the form size is used. The exported pictures will be exactly the same
as the pictures that you see on the form. Before saving the pictures, it is best to check them all
by using the Prev and Next buttons. Even when the Fit option is enabled, there isn't always
enough space, since there is a minimum space per note required. To solve that you can
increase the form size, decrease the number of bars per picture or decrease the scale
percentage. In the following example there is not enough space.
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You can export pictures as png, bmp, gif and jpg. Press Save picture to save only the current
picture. Press Save all to save all pictures. In that case the filename(s) will include a number.

For printing, the dimensions of the page will be used. Before printing on paper, it is handy to
print to a pdf file. When there is not enough space, you can decrease the margins (L=left,
R=right, T=top, B=bottom) or decrease the scale percentage.
Press Print to print all pictures. There will be 1 picture per page.

You can specify the pages that you want to print or change the orientation (Portrait or
Landscape). Perhaps you will need to choose Landscape if you have a big chromatic kalimba.

Mark lowest tone

Enable this option, if you want the tine with the lowest pitch to be surrounded by a thick line.
This makes it easier to find the notes on your kalimba.

Auto beaming

Enable Auto beaming, if you want to connect notes with less rhythmic value than a quarter
note. Note beaming makes it much easier to read the tab. The beam grouping depends on the
time signature. For a time signature there can be more possible groupings. Therefore you can
enter a beam grouping on the main form. Valid groupings for a 9/8 time signature are 333,
3222, 2322, 2232 and 2223. If you leave Beam grouping empty, 333 will be used.
Take a look at the following examples.
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The grouping in the left picture is 32 and the grouping in the right picture is 23.

For creating the following picture, Auto beaming was disabled.
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Note spacing

This setting is only used when Fit is disabled. If the note spacing is 0%, the minimum space
per note is used which is the same for every note. When the same note is entered in 2
contiguous rows and the first note is a double dotted note, there is not enough space and you
need to increase the note spacing. If the note spacing is 100%, the distance between the notes
is the most realistic, but it takes a lot of space. Normally a note spacing of around 50% is
more practical. In the left picture the note spacing is 100% and in the right picture the note
spacing is 50%.

It is handy to enable Fit, since then the note spacing is calculated automatically depending on
the available space.
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Exporting to a MIDI file

Choose Export MIDI from the File menu to export the current kalimba tab to a MIDI file.
Read the Changing the settings chapter for the MIDI export settings.


